dcs - domain configuration server
/usr/lib/dcs [-s sessions]
The Domain Configuration Server (DCS) is a daemon process
that runs on Sun servers that support remote Dynamic Recon-
figuration (DR) clients. It is started by inetd(1M) when the
first DR request is received from a client connecting to the
network service sun-dr. After the DCS accepts a DR request,
it uses the libcfgadm(3LIB) interface to execute the DR
operation. After the operation is performed, the results are
returned to the client.
The DCS listens on the network service labeled sun-dr. Its
underlying protocol is TCP, and it is invoked as an inetd
server using the TCP transport. The entries for the DCS in
the /etc/inet/inetd.conf file are as follows:
sun-dr stream tcp wait root /usr/lib/dcs dcs
sun-dr stream tcp6 wait root /usr/lib/dcs dcs
These entries enable remote DR operations. If you remove the
entries, DR operations initiated from a remote host fail.
There is no negative impact on the server. If you are using
a Sun Fire high-end system and IPSec is configured on the
sun-dr port (port 665), you must also remove the policies in
/etc/inet/ipsecinit.conf that reference the sun-dr port,
then use the ipsecconf(1M) command with appropriate options
to flush the policies.
If you remove the sun-dr entries from /etc/inet/inetd.conf
without deleting and flushing the corresponding entries from
/etc/inet/ipsecinit.conf, any process that attempts to use
the sun-dr port will hang. This is because the IPSec policy
is still in effect for that port.
The following options are supported:
Set the number of active sessions that the DCS allows
at any one time. When the limit is reached, the DCS
stops accepting connections until active sessions com-
plete the execution of their DR operation. If this
option is not specified, a default value of 128 is
The DCS uses syslog(3C) to report status and error messages.
All of the messages are logged with the LOG_DAEMON facility.
Error messages are logged with the LOG_ERR and LOG_NOTICE
priorities, and informational messages are logged with the
LOG_INFO priority. The default entries in the
/etc/syslog.conf file log all of the DCS error messages to
the /var/adm/messages log.
See attributes(5) for descriptions of the following attri-
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
| Availability | SUNWdcsu, SUNWdcsr |
cfgadm_sbd(1M), inetd(1M), ipsecconf(1M), syslog(3C),
config_admin(3CFGADM), libcfgadm(3LIB), inetd.conf(4),
syslog.conf(4), attributes(5), dr(7D)
Man(1) output converted with