devreserv(1M)




NAME

     devreserv - reserve devices for exclusive use


SYNOPSIS

     devreserv [ key [device-list...]]


DESCRIPTION

     devreserv reserves devices for exclusive use. When the  dev-
     ice is no longer required, use  devfree to release it.

     devreserv reserves at most one device per  device-list. Each
     list  is  searched in linear order until the first available
     device is found. If a device cannot be  reserved  from  each
     list, the entire reservation fails.

     When  devreserv is invoked without arguments, it  lists  the
     devices  that  are currently reserved and shows to which key
     it was reserved. When  devreserv is invoked  with  only  the
     key  argument,  it  lists  the  devices  that  are currently
     reserved to that key.


OPERANDS

     The following operands are supported:

     device-list
           Defines a list of devices that devreserv  will  search
           to  find an available device. The list must be format-
           ted as a single argument to the shell.

     key   Designates a unique key on which the  device  will  be
           reserved. The key must be a positive integer.


EXAMPLES

     Example 1: Reserving a Floppy Disk and a Cartridge Tape

     The following example reserves a floppy disk and a cartridge
     tape:

     $ key=$$
     $ echo "The current Process ID is equal to: $key"
       The Current Process ID is equal to: 10658
     $ devreserv $key diskette1 ctape1

     Example 2: Listing All Devices Currently Reserved

     The following example lists all devices currently reserved:

     $ devreserv
       disk1         2423
       diskette1     10658
       ctape1        10658

     Example 3: Listing All Devices Currently Reserved to a  Par-
     ticular Key

     The following example lists all devices  currently  reserved
     to a particular key:

     $ devreserv $key
       diskette1
       ctape1


EXIT STATUS

     The following exit values are returned:

     0     Successful completion.

     1     Command syntax was incorrect, an  invalid  was  option
           used, or an internal error occurred.

     2     Device table or device reservation table could not  be
           opened for reading.

     3     Device reservation request could not be fulfilled.


FILES

     /etc/device.tab

     /etc/devlkfile


ATTRIBUTES

     See attributes(5) for descriptions of the  following  attri-
     butes:

     ____________________________________________________________
    |       ATTRIBUTE TYPE        |       ATTRIBUTE VALUE       |
    |_____________________________|_____________________________|
    | Availability                | SUNWcsu                     |
    |_____________________________|_____________________________|


SEE ALSO

     devfree(1M), attributes(5)


NOTES

     The commands devreserv and devfree are used  to  manage  the
     availability of devices on a system. Their use is  on a par-
     ticipatory basis and they do not place any   constraints  on
     the actual access to the device. They serve as a centralized
     bookkeeping point for those who wish to  use  them.  Devices
     which  have been reserved  cannot be used by processes which
     utilize  the  device   reservation   functions   until   the
     reservation  has  been  canceled. However, processes that do
     not use device reservation may use a device  that  has  been
     reserved since such a process would not have checked for its
     reservation status.


Man(1) output converted with man2html