ifconfig(1M)




NAME

     ifconfig - configure network interface parameters


SYNOPSIS

     /sbin/ifconfig   interface   [address_family]   [   address
     [/prefix_length]     [dest_address]]   [   addif    address
     [/prefix_length]]  [  removeif   address   [/prefix_length]]
     [arp   |   -arp]    [auth_algs   authentication   algorithm]
     [encr_algs encryption                             algorithm]
     [encr_auth_algs authentication  algorithm]  [auto-revarp]  [
     broadcast  address] [deprecated | -deprecated]   [  destina-
     tion   dest_address]  [ [failover] | [-failover]]  [ group [
     [name] | ""] ] [ index   {if_index}] [ metric  n]  [modlist]
     [modinsert  mod_name@pos] [modremove mod_name@pos] [ mtu  n]
     [ netmask  mask]  [plumb]  [unplumb]  [private  |  -private]
     [nud  |  -nud]   [ set  [address]  [/netmask]] [ [standby] |
     [-standby]]    [    subnet     subnet_address]    [    tdst
     tunnel_dest_address]  [  token     address/prefix_length]  [
     tsrc   tunnel_src_address]  [trailers  |  -trailers]    [up]
     [down]  [xmit | -xmit]  [encaplimit  n | -encaplimit]  [tho-
     plimit  n]

     /usr/sbin/ifconfig  interface  [address_family]  [  address
     [/prefix_length]     [dest_address]]   [   addif    address
     [/prefix_length]]  [  removeif   address   [/prefix_length]]
     [arp   |   -arp]    [auth_algs   authentication   algorithm]
     [encr_algs encryption                             algorithm]
     [encr_auth_algs authentication  algorithm]  [auto-revarp]  [
     broadcast  address] [deprecated | -deprecated]   [  destina-
     tion   dest_address]  [ [failover] | [-failover]]  [ group [
     [name] | ""] ] [ index   {if_index}] [ metric  n]  [modlist]
     [modinsert  mod_name@pos] [modremove mod_name@pos] [ mtu  n]
     [ netmask  mask]  [plumb]  [unplumb]  [private  |  -private]
     [nud  |  -nud]   [ set  [address]  [/netmask]] [ [standby] |
     [-standby]]    [    subnet     subnet_address]    [    tdst
     tunnel_dest_address]  [  token     address/prefix_length]  [
     tsrc   tunnel_src_address]  [trailers  |  -trailers]    [up]
     [down]  [xmit  |  -xmit]   [encaplimit   n  | -encaplimit  ]
     [thoplimit  n]

     /sbin/ifconfig  interface {auto-dhcp |  dhcp}   [primary]  [
     wait   seconds]   drop  | extend | inform | ping | release |
     start | status

     /usr/sbin/ifconfig  interface {auto-dhcp | dhcp}   [primary]
     [  wait  seconds]  drop | extend | inform | ping | release |
     start | status


DESCRIPTION

     The command ifconfig is used to assign an address to a  net-
     work  interface  and  to configure network interface parame-
     ters. The ifconfig command must be  used  at  boot  time  to
     define  the  network  address of each interface present on a
     machine; it may also be used at a later time to redefine  an
     interface's  address  or  other  operating parameters. If no
     option is specified, ifconfig displays  the  current  confi-
     guration  for  a  network interface. If an address family is
     specified, ifconfig reports only  the  details  specific  to
     that  address family. Only the superuser may modify the con-
     figuration of a network interface. Options appearing  within
     braces  ({}) indicate that one of the options must be speci-
     fied.

     The   two   versions   of   ifconfig,   /sbin/ifconfig   and
     /usr/sbin/ifconfig,  behave differently with respect to name
     services.  The  order  in  which  names  are  looked  up  by
     /sbin/ifconfig  when the system is booting is fixed and can-
     not be changed. In contrast, changing /etc/nsswitch.conf may
     affect   the  behavior  of  /usr/sbin/ifconfig.  The  system
     administrator may configure the source and lookup  order  in
     the   tables  by  means  of  the  name  service  switch. See
     nsswitch.conf(4) for more information.

  DHCP Configuration
     The third and fourth forms of this command are used to  con-
     trol the Dynamic Host Configuration Protocol ("DHCP") confi-
     guring of the interface. DHCP is only  available  on  inter-
     faces  for  which  the address family is inet. In this mode,
     ifconfig is used to control operation of dhcpagent(1M),  the
     DHCP  client  daemon. Once an interface is placed under DHCP
     control by using the start operand, ifconfig should not,  in
     normal  operation,  be used to modify the address or charac-
     teristics of the interface. If the address of  an  interface
     under  DHCP  is changed, dhcpagent will remove the interface
     from its control.


OPTIONS

     The following options are supported:

     addif address
           Create the next unused logical interface on the speci-
           fied physical interface.

     arp   Enable the use  of  the  Address  Resolution  Protocol
           ("ARP") in mapping between network level addresses and
           link level  addresses  (default).  This  is  currently
           implemented  for  mapping  between  IPv4 addresses and
           10Mb/s Ethernet addresses.

     -arp  Disable the use of the ARP.

     auth_algs authentication algorithm
           For a tunnel, enable IPsec AH with the  authentication
           algorithm  specified.  The  algorithm  can be either a
           number or an algorithm name, including any to  express
           no  preference  in algorithm. All IPsec tunnel proper-
           ties must be specified on the same  command  line.  To
           disable tunnel security, specify an auth_alg of none.

     auto-dhcp
           Use DHCP to automatically acquire an address for  this
           interface.  This  option  has  a completely equivalent
           alias called dhcp.

           primary
                 Defines the interface as the primary. The inter-
                 face  is  defined  as  the preferred one for the
                 delivery of client-wide configuration data. Only
                 one  interface  can  be the primary at any given
                 time.  If  another  interface  is   subsequently
                 selected  as the primary, it replaces the previ-
                 ous one. Nominating an interface as the  primary
                 one  will  not  have  much significance once the
                 client work station has booted, as many applica-
                 tions will already have started and been config-
                 ured with data read from  the  previous  primary
                 interface.

           wait seconds
                 The ifconfig command will wait until the  opera-
                 tion either completes or for the interval speci-
                 fied, whichever is the sooner. If no wait inter-
                 val is given, and the operation is one that can-
                 not complete immediately, ifconfig will wait  30
                 seconds for the requested operation to complete.
                 The symbolic value forever may be used as  well,
                 with obvious meaning.

           drop  Remove the specified interface  from  DHCP  con-
                 trol.  Additionally,  set the IP address to zero
                 and mark the interface as "down".

           extend
                 Attempt to extend the lease on  the  interface's
                 IPv4 address. This is not required, as the agent
                 will automatically extend the lease well  before
                 it expires.

           inform
                 Obtain  network  configuration  parameters  from
                 DHCP without obtaining a lease on an IP address.
                 This is useful in situations where an IP address
                 is obtained through mechanisms other than DHCP.

           ping  Check whether the interface given is under  DHCP
                 control,  which  means  that  the  interface  is
                 managed by the DHCP agent and is  working  prop-
                 erly.  An  exit  status of 0 means success. This
                 subcommand has no meaning when the named  inter-
                 face represents more than one interface.

           release
                 Relinquish the IPv4 address  on  the  interface,
                 and mark the interface as "down."

           start Start DHCP on the interface.

           status
                 Display the DHCP  configuration  status  of  the
                 interface.

     auto-revarp
           Use the Reverse Address Resolution  Protocol  ("RARP")
           to  automatically  acquire  an address for this inter-
           face.

     broadcast address
           For IPv4 only. Specify the address to use to represent
           broadcasts  to  the  network.  The  default  broadcast
           address is the address with a host part of all 1's.  A
           "+"  (plus  sign) given for the broadcast value causes
           the  broadcast  address  to  be  reset  to  a  default
           appropriate  for  the  (possibly new) address and net-
           mask. The arguments of ifconfig are  interpreted  left
           to right. Therefore

           example% ifconfig -a netmask + broadcast +

            and

           example% ifconfig -a broadcast + netmask +

           may result in different values being assigned for  the
           broadcast addresses of the interfaces.

     deprecated
           Marks the address as a deprecated  address.  Addresses
           marked  as  deprecated  will  not  be  used  as source
           address for outbound packets unless either  there  are
           no  other addresses available on this interface or the
           application has bound to this address explicitly.  The
           status  display shows DEPRECATED as part of flags. See
           INTERFACE FLAGS for information on the flags supported
           by ifconfig.

     -deprecated
           Marks the address as not deprecated.

     destination dest_address
           Set the  destination  address  for  a  point-to  point
           interface.

     dhcp  This option is an alias for option auto-dhcp

     down  Mark an interface "down". When an interface is  marked
           "down",  the  system does not attempt to transmit mes-
           sages through that interface. If possible, the  inter-
           face  is  reset  to  disable  reception  as well. This
           action does not automatically disable routes using the
           interface.

     encaplimit n
           Set the tunnel encapsulation limit for  the  interface
           to  n.  This  option applies to IPv4-in-IPv6 and IPv6-
           in-IPv6 tunnels only. The tunnel  encapsulation  limit
           controls  how  many  more  tunnels  a packet may enter
           before it leaves any  tunnels,  that  is,  the  tunnel
           nesting level.

     -encaplimit
           Disable generation of the tunnel encapsulation  limit.
           This  option applies only to IPv4-in-IPv6 and IPv6-in-
           IPv6 tunnels.

     encr_auth_algs authentication algorithm
           For a tunnel, enable IPsec ESP with the authentication
           algorithm  specified.  It can be either a number or an
           algorithm name, including any or none, to indicate  no
           algorithm  preference.  If an ESP encryption algorithm
           is specified but the authentication algorithm is  not,
           the default value for the ESP authentication algorithm
           will be any.

     encr_algs encryption algorithm
           For a tunnel, enable IPsec  ESP  with  the  encryption
           algorithm  specified.  It can be either a number or an
           algorithm name. Note that all IPsec tunnel  properties
           must be specified on the same command line. To disable
           tunnel security, specify  the  value  of  encr_alg  as
           none. If an ESP authentication algorithm is specified,
           but the encryption algorithm is not, the default value
           for the ESP encryption will be null.

     -failover
           Mark the address as a  non-failover  address.Addresses
           marked  this  way will not failover when the interface
           fails. Status display shows "NOFAILOVER"  as  part  of
           flags.

     failover
           Mark the address as a failover address.  This  address
           will failover when the interface fails. Status display
           does not show "NOFAILOVER" as part of flags.

     group [ name |""]
           Insert the interface in the multipathing group  speci-
           fied by name. To delete an interface from a group, use
           a null string "".
            When invoked on the logical interface with  id  zero,
           the status display shows the group name.

     index n
           Change the interface  index  for  the  interface.  The
           value  of n must be an interface index (if_index) that
           is not used on another interface. if_index  will be  a
           non-zero  positive number that uniquely identifies the
           network interface on the system.

     metric n
           Set the routing metric of the interface to  n;  if  no
           value  is  specified,  the  default is  0. The routing
           metric is used by the routing protocol. Higher metrics
           have  the  effect  of  making  a route less favorable.
           Metrics are counted as addition hops to  the  destina-
           tion network or host.

     modinsert mod_name@pos
           Insert a module with name mod_name to  the  stream  of
           the  device  at position pos. The position is relative
           to the stream head.
            Position 0 means directly under stream head.

           Based upon the example in the modlist option, use  the
           following  command  to insert a module with name ipqos
           under the ip module and above the firewall module:

           example% ifconfig hme0 modinsert ipqos@2

           A subsequent listing of all the modules in the  stream
           of the device follows:

     example% ifconfig hme0 modlist
     0 arp
     1 ip
     2 ipqos
     3 firewall
     4 hme

     modlist
           List all the modules in the stream of the device.

           The following example lists all  the  modules  in  the
           stream of the device:

     example% ifconfig hme0 modlist
     0 arp
     1 ip
     2 firewall
     4 hme

     modremove mod_name@pos
           Remove a module with name mod_name from the stream  of
           the  device  at position pos. The position is relative
           to the stream head.

           Based upon the example in the  modinsert  option,  use
           the  following  command  to remove the firewall module
           from the stream after inserting the ipqos module:

           example% ifconfig hme0 modremove firewall@3

           A subsequent listing of all the modules in the  stream
           of the device follows:

           example% ifconfig hme0 modlist
           0 arp
           1 ip
           2 ipqos
           3 hme

           Note that the core IP stack modules, for  example,  ip
           and tun modules, cannot be removed.

     mtu  n
           Set the maximum transmission unit of the interface  to
           n.  For  many  types of networks, the mtu has an upper
           limit, for example,  1500 for Ethernet.

     netmask  mask
           For IPv4 only. Specify how  much  of  the  address  to
           reserve for subdividing networks into subnetworks. The
           mask includes the network part of  the  local  address
           and  the  subnet  part,  which  is taken from the host
           field of the address. The mask contains  1's  for  the
           bit  positions  in  the 32-bit address which are to be
           used for the network and subnet parts, and 0's for the
           host  part. The mask should contain at least the stan-
           dard network portion, and the subnet field  should  be
           contiguous  with  the network portion. The mask can be
           specified in one of four ways:

           1. with a single hexadecimal  number  with  a  leading
              0x,

           2. with a dot-notation address,

           3. with a "+" (plus sign) address, or

           4. with a pseudo host name/pseudo  network name  found
              in the network database  networks(4).

     If a "+" (plus sign) is given for the  netmask  value,   the
     mask  is looked up in the  netmasks(4) database. This lookup
     finds the longest matching netmask in the database by start-
     ing  with the interface's IPv4 address as the key and itera-
     tively masking off more and  more  low  order  bits  of  the
     address.  This iterative lookup ensures that the netmasks(4)
     database can be used to specify the netmasks  when  variable
     length subnetmasks are used within a network number.

     If a pseudo host name/pseudo network name is supplied as the
     netmask  value,  netmask data may be located in the hosts or
     networks database.  Names  are  looked  up  by  first  using
     gethostbyname(3NSL).  If  not  found  there,  the  names are
     looked up in getnetbyname(3SOCKET).  These interfaces may in
     turn use nsswitch.conf(4) to determine what data store(s) to
     use to fetch the actual value.

           For both inet and inet6, the same information conveyed
           by  mask  can be specified as a prefix_length attached
           to the address parameter.

     nud   Enables the neighbor unreachability detection  mechan-
           ism on a point-to-go interface.

     -nud  Disables the neighbor unreachability detection mechan-
           ism on a point-to-go interface.

     plumb Open the device associated with the physical interface
           name  and set up the streams needed for  IP to use the
           device. When used with a logical interface name,  this
           command  is  used  to  create a specific named logical
           interface. An interface must be separately plumbed for
           use  by  IPv4  and  IPv6. The address_family parameter
           controls whether the ifconfig command applies to  IPv4
           or IPv6.

            Before an interface has been plumbed,  the  interface
           will not show up in the output of the ifconfig -a com-
           mand.

     private
           Tells the in.routed routing daemon that the  interface
           should not be advertised.

     -private
           Specify unadvertised interfaces.

     removeif address
           Remove the logical interface on the   physical  inter-
           face specified that matches the address specified.

     set   Set the  address,   prefix_length  or  both,   for  an
           interface.

     standby
           Marks the physical interface as a  standby  interface.
           If  the interface is marked STANDBY and is part of the
           multipathing group, the interface will not be selected
           to send out packets unless some other interface in the
           group has failed  and  the  network  access  has  been
           failed over to this standby interface.

           The status display shows "STANDBY, INACTIVE"  indicat-
           ing  that  that the interface is a standby and is also
           inactive.  IFF_INACTIVE  will  be  cleared  when  some
           other  interface  belonging  to  the same multipathing
           group fails over to this interface.  Once  a  failback
           happens, the status display will return to INACTIVE.

     -standby
           Turns off standby on this interface.

     subnet
           Set the subnet address for an interface.

     tdst tunnel_dest_address
           Set the destination address of a tunnel.  The  address
           should not be the same as the dest_address of the tun-
           nel, because no packets  leave the system over such  a
           tunnel.

     thoplimit n
           Set the hop limit for  a  tunnel  interface.  The  hop
           limit  value is used as the TTL in the IPv4 header for
           the IPv6-in-IPv4 and IPv4-in-IPv4 tunnels.  For  IPv6-
           in-IPv6  and IPv4-in-IPv6 tunnels, the hop limit value
           is used as the hop limit in the IPv6 header.

     token address/prefix_length
           Set the IPv6 token of an  interface  to  be  used  for
           address autoconfiguration.

           example% ifconfig hme0 inet6 token ::1/64

     trailers
           This flag previously caused a  nonstandard  encapsula-
           tion  of  inet packets on certain link levels. Drivers
           supplied with this release no longer use this flag. It
           is provided for compatibility, but is ignored.

     -trailers
           Disable the use of a "trailer" link  level  encapsula-
           tion.

     tsrc tunnel_src_address
           Set the source address of a tunnel. This is the source
           address  on  an outer encapsulating IP header. It must
           be an address of another interface already  configured
           using ifconfig.

     unplumb
           Close the device associated with this physical  inter-
           face  name and any streams that ifconfig set up for IP
           to use the device. When used with a logical  interface
           name,  the  logical interface is removed from the sys-
           tem. After this command is executed, the  device  name
           will no longer appear in the output of ifconfig -a.

     up    Mark an interface  "up".  This  happens  automatically
           when setting the first address on an interface. The up
           option enables an interface after  an  ifconfig  down,
           which reinitializes the hardware.

     xmit  Enable an interface to transmit packets. This  is  the
           default behavior when the interface is up.

     -xmit Disable transmission of packets on an  interface.  The
           interface will continue to receive packets.


OPERANDS

     The interface operand, as well as  address  parameters  that
     affect it, are described below.

          interface
                A string of one of the following forms:

                   o  name physical-unit,  for  example,  le0  or
                      ie1

                   o  name physical-unit:logical-unit, for  exam-
                      ple, le0:1

                   o  ip.tunN or ip6.tunN, for tunnels
                If the interface name starts with a dash (-),  it
                is  interpreted as a set of options which specify
                a set of interfaces. In such a case, -a  must  be
                part  of  the  options  and any of the additional
                options below can be added in any order.  If  one
                of  these  interface names is given, the commands
                following it are applied to all of the interfaces
                that match.

                -a    Apply the command to all interfaces of  the
                      specified  address  family.  If  no address
                      family is supplied, either on  the  command
                      line or by means of /etc/default/inet_type,
                      then all address families will be selected.

                -d    Apply the commands to all "down" interfaces
                      in the system.

                -D    Apply the commands to all  interfaces   not
                      under DHCP (Dynamic Host Configuration Pro-
                      tocol) control.

                -u    Apply the commands to all  "up"  interfaces
                      in the system.

                -4    Apply the commands to all IPv4 interfaces.

                -6    Apply the commands to all IPv6 interfaces.

          address_family
                The  address   family   is   specified   by   the
                address_family  parameter.  The  ifconfig command
                currently supports the following families: ether,
                inet,  and  inet6. If no address family is speci-
                fied, the  default  is  inet.  No  ether  address
                information is provided to non-root users.

                ifconfig honors the  DEFAULT_IP  setting  in  the
                /etc/default/inet_type   file  when  it  displays
                interface information . If DEFAULT_IP is  set  to
                IP_VERSION4,  then ifconfig will omit information
                that relates to IPv6  interfaces.  However,  when
                you explicitly specify an address family (inet or
                inet6) on the ifconfig command line, the  command
                line overrides the DEFAULT_IP settings.

          address
                For the IPv4 family (inet), the address is either
                a  host  name  present in the host name data base
                (see hosts(4)) or in the Network Information Ser-
                vice   (NIS)   map  hosts,  or  an  IPv4  address
                expressed in the  Internet  standard  "dot  nota-
                tion".

                For the  IPv6  family  (inet6),  the  address  is
                either  a host name present in the host name data
                base (see ipnodes(4)) or in the Network  Informa-
                tion Service (NIS) map ipnode, or an IPv6 address
                expressed  in  the   Internet   standard   colon-
                separated   hexadecimal   format  represented  as
                x:x:x:x:x:x:x:x where x is a  hexadecimal  number
                between 0 and FFFF.

                For the ether address family, the address  is  an
                Ethernet  address  represented  as  x:x:x:  x:x:x
                where x is a hexadecimal number  between   0  and
                FF.

                Some, though not all, of the  Ethernet  interface
                cards have their own addresses. To use cards that
                do not have their own addresses, refer to section
                3.2.3(4)  of  the  IEEE 802.3 specification for a
                definition of the  locally  administered  address
                space. The use of interface groups should be res-
                tricted to those cards with their  own  addresses
                (see INTERFACE GROUPS).

          prefix_length
                For the IPv4 and IPv6 families (inet and  inet6),
                the  prefix_length  is a number between 0 and the
                number of bits in  the  address.  For  inet,  the
                number  of  bits in the address is 32; for inet6,
                the number of bits in the address  is   128.  The
                prefix_length  denotes  the number of leading set
                bits in the netmask.

          dest_address
                If the  dest_address  parameter  is  supplied  in
                addition  to  the address parameter, it specifies
                the address of the correspondent on the other end
                of a point-to-point link.

          tunnel_dest_address
                An address that is or will be  reachable  through
                an  interface other than the tunnel being config-
                ured. This tells the tunnel  where  to  send  the
                tunneled  packets.  This  address must not be the
                same as the tunnel_dest_address being configured.

          tunnel_src_address
                An address that is attached to an already config-
                ured interface that has been configured "up" with
                ifconfig.


INTERFACE FLAGS

     The ifconfig command supports the following interface flags.
     The  term  "address"  in  this  context  refers to a logical
     interface, for example, hme0:0, while "interface " refers to
     the physical interface, for example, hme0.

     ADDRCONF
           The address is from stateless addrconf. The  stateless
           mechanism  allows  a  host to generate its own address
           using  a  combination  of  information  advertised  by
           routers  and  locally  available  information. Routers
           advertise prefixes that identify the subnet associated
           with  the link, while the host generates an "interface
           identifier" that uniquely identifies an interface in a
           subnet.  In the absence of information from routers, a
           host can generate link-local addresses. This  flag  is
           specific to IPv6.

     ANYCAST
           Indicates an anycast address. An anycast address iden-
           tifies  the  nearest member of a group of systems that
           provides a particular  type  of  service.  An  anycast
           address is assigned to a group of systems. Packets are
           delivered to the nearest group  member  identified  by
           the  anycast address instead of being delivered to all
           members of the group. This flag is specific to IPv6.

     BROADCAST
           This broadcast address is valid. This flag and  POINT-
           TOPOINT are mutually exclusive

     CoS   This interface supports some form of Class of  Service
           (CoS)  marking. An example is the 802.1D user priority
           marking supported on VLAN interfaces.

     DEPRECATED
           This address is deprecated. This address will  not  be
           used  as  a source address for outbound packets unless
           there are no other addresses on this interface  or  an
           application  has  explicitly bound to this address. An
           IPv6 deprecated address  will  eventually  be  deleted
           when  not  used, whereas an IPv4 deprecated address is
           often used with  IP  network  multipathing  IPv4  test
           addresses,  which are determined by the setting of the
           NOFAILOVER flag. Further, the DEPRECATED flag is  part
           of the standard mechanism for renumbering in IPv6.

     DHCP  DHCP is used to manage this address.

     FAILED
           The interface has failed.  New  addresses   cannot  be
           created  on  this interface. If this interface is part
           of an IP network multipathing group, a  failover  will
           occur to another interface in the group, if possible

     INACTIVE
           Only set on standby interfaces, this flag indicates no
           failover  has occurred to the interface. New addresses
           cannot be created on  this  interface.  This  flag  is
           cleared if a failover occurs to the interface.

     LOOPBACK
           Indicates that this is the loopback interface.

     MIP   Indicates that mobile IP controls this interface.

     MULTI_BCAST
           Indicates that the broadcast address is used for  mul-
           ticast on this interface.

     MULTICAST
           The interface supports multicast. IP assumes that  any
           interface that supports hardware broadcast, or that is
           a point-to-point link, will support multicast.

     NOARP There is no address resolution protocol (ARP) for this
           interface  that  corresponds  to  all interfaces for a
           device without  a  broadcast  address.  This  flag  is
           specific to IPv4.

     NOFAILOVER
           This address will not failover if the interface fails.
           IP  network multipathing test addresses must be marked
           nofailover.

     NOLOCAL
           The interface has no address , just  an  on-link  sub-
           net.

     NONUD NONUD is disabled on  this  interface.  NUD  (neighbor
           unreachability  detection)  is used by a node to track
           the reachability state of its neighbors, to which  the
           node  actively  sends  packets,  and  to  perform  any
           recovery if a neighbor is detected to be  unreachable.
           This flag is specific to IPv6.

     NORTEXCH
           The interface does not exchange  routing  information.
           For  RIP-2,  routing  packets  are  not sent over this
           interface. Additionally, messages that appear to  come
           over this interface receive no response. The subnet or
           address of this interface is not  included  in  adver-
           tisements over other interfaces to other routers.

     NOXMIT
           Indicates that the address does not transmit  packets.
           RIP-2 also does not advertise this address.

     OFFLINE
           Indicates that the interface has  been  offlined.  New
           addresses  cannot be created on this interface. Inter-
           faces in an IP network multipathing group are offlined
           prior  to removal and replacement using dynamic recon-
           figuration.

     POINTOPOINT
           Indicates that the address is a  point-to-point  link.
           This flag and BROADCAST are mutually exclusive

     PRIVATE
           Indicates that this address  is  not  advertised.  For
           RIP-2,  this interface is used to send advertisements.
           However, neither  the  subnet  nor  this  address  are
           included in advertisements to other routers.

     RUNNING
           Indicates that the required resources for an interface
           are allocated. For some interfaces this also indicates
           that the link is up.

     STANDBY
           Indicates that this is a standby interface to be  used
           on  failures.  Only  interfaces  in an IP network mul-
           tipathing group should be designated as standby inter-
           faces.  If this interface is part of a IP network mul-
           tipathing group, the interface will not be selected to
           send  out  packets  unless some other interface in the
           group fails over to it.

     UNNUMBERED
           This flag is set when the local IP address on the link
           matches  the  local  address of some other link in the
           system

     UP    Indicates that the interface is up, that is,  all  the
           routing  entries  and the like for this interface have
           been set up.

     XRESOLV
           Indicates that the interface  uses  an  IPv6  external
           resolver.


LOGICAL INTERFACES

     Solaris TCP/IP allows  multiple  logical  interfaces  to  be
     associated  with a physical network interface. This allows a
     single machine to be assigned multiple  IP  addresses,  even
     though it may have only one network interface. Physical net-
     work  interfaces  have  names  of   the   form   driver-name
     physical-unit-number, while logical interfaces have names of
     the  form   driver-name   physical-unit-number:logical-unit-
     number.  A  physical interface is configured into the system
     using the plumb command. For example:

     example% ifconfig le0 plumb

     Once a physical interface has been "plumbed", logical inter-
     faces  associated with the physical interface can be config-
     ured by separate plumb or addif   options  to  the  ifconfig
     command.

     example% ifconfig le0:1 plumb

     allocates a specific logical interface associated  with  the
     physical interface le0. The command

     example% ifconfig le0 addif 192.9.200.1/24 up

     allocates the next available logical unit number on the  le0
     physical interface and assigns an address and prefix_length.

     A logical interface can  be  configured  with  parameters  (
     address,prefix_length,  and so on) different from the physi-
     cal interface with which it is  associated.  Logical  inter-
     faces  that  are associated with the same physical interface
     can be given different  parameters  as  well.  Each  logical
     interface  must be associated with an existing and "up" phy-
     sical interface. So,  for  example,  the  logical  interface
     le0:1  can  only  be configured after the physical interface
     le0 has been plumbed.

     To delete a logical interface, use the unplumb  or  removeif
     options. For example,

     example% ifconfig le0:1 down unplumb

     will delete the logical interface  le0:1.


INTERFACE GROUPS

     If a physical interface shares an  IP  prefix  with  another
     interface,  these interfaces are collected into an interface
     group. IP uses an interface group to rotate  source  address
     selection when the source address is unspecified, and in the
     case of multiple physical interfaces in the same  group,  to
     scatter  traffic  across different IP addresses on a per-IP-
     destination basis. See  netstat(1M)  for  per-IP-destination
     information.

     This feature may be enabled by using ndd(1M).

     One can also use the group keyword to  form  a  multipathing
     group.  When multipathing groups are used, the functionality
     of the interface group is subsumed into the functionality of
     the   multipathing  group.  A  multipathing  group  provides
     failure detection and repair detection for the interfaces in
     the  group.  See  in.mpathd(1M)  and  System  Administration
     Guide: IP Services.

     The interface groups  formed  using  ndd(1M)  will  be  made
     obsolete  in the future. Accordingly, it is advisable to use
     form multipathing groups using the group keyword.


CONFIGURING IPv6 INTERFACES

     When an IPv6 physical interface is  plumbed  and  configured
     "up"  with  ifconfig,  it  is automatically assigned an IPv6
     link-local address for which the last 64 bits are calculated
     from the MAC address of the interface.

     example% ifconfig eri0 inet6 plumb up

     The following example shows that the link-local address  has
     a prefix of fe80::/10.

     example% ifconfig eri0 inet6
     ce0: flags=2000841<UP,RUNNING,MULTICAST,IPv6>
                mtu 1500 index 2
             inet6 fe80::a00:20ff:fe8e:f3ad/10

     Link-local addresses are only used for communication on  the
     local subnet and are not visible to other subnets.

     If an advertising IPv6 router exists on the link advertising
     prefixes,  then  the newly plumbed IPv6 interface will auto-
     configure  logical  interface(s)  depending  on  the  prefix
     advertisements.  For  example,  for the prefix advertisement
     2001:0db8:3c4d:0:55::/64, the autoconfigured interface  will
     look like:

     eri0:2: flags=2080841<UP,RUNNING,MULTICAST,ADDRCONF,IPv6>
               mtu 1500 index 2
             inet6 2001:0db8:3c4d:55:a00:20ff:fe8e:f3ad/64

     Even if there are no prefix advertisements on the link,  you
     can still assign global addresses manually, for example:

     example% ifconfig eri0 inet6 addif 2001:0db8:3c4d:55:a00:20ff:fe8e:f3ad/64 up

     To configure boot-time  defaults  for  the  interface  eri0,
     place the following entry in the /etc/hostname6.eri0 file:

     addif  2001:0db8:3c4d:55:a00:20ff:fe8e:f3ad/64 up

  Configuring IPv6/IPv4 tunnels
     An IPv6 over IPv4 tunnel interface can send and receive IPv6
     packets  encapsulated  in an IPv4 packet. Create tunnels  at
     both ends pointing to each other.  IPv6  over  IPv4  tunnels
     require  the  tunnel  source and tunnel destination IPv4 and
     IPv6 addresses. Solaris 8 supports both automatic  and  con-
     figured  tunnels.  For automatic tunnels, an IPv4-compatible
     IPv6 address is used. The following demonstrates auto-tunnel
     configuration:

     example% ifconfig ip.atun0 inet6 plumb

     example% ifconfig ip.atun0 inet6 tsrc IPv4-address \
        ::IPv4 address/96 up

     where IPv4-address is the  IPv4  address  of  the  interface
     through  which  the  tunnel  traffic  will  flow,  and IPv4-
     address,  ::<IPv4-address>,  is  the   corresponding   IPv4-
     compatible IPv6 address.

     The following is an example of a configured tunnel:

     example% ifconfig ip.tun0 inet6 plumb tsrc my-ipv4-address \
        tdst peer-ipv4-address up

     This creates a configured tunnel between my-ipv4-address and
     peer-ipv4-address  with  corresponding link-local addresses.
     For tunnels with global or site-local addresses, the logical
     tunnel  interfaces  need  to  be configured in the following
     form:

     example% ifconfig ip.tun0 inet6 addif my-v6-address peer-v6-address up

     For example,

     example% ifconfig ip.tun0 inet6 plumb tsrc 109.146.85.57 \
        tdst 109.146.85.212 up
     example% ifconfig ip.tun0 inet6 addif 2::45 2::46 up

     To show all IPv6 interfaces that are up and configured:

     example% ifconfig -au6
     ip.tun0: flags=2200851<UP,POINTOPOINT,RUNNING,MULTICAST,NONUD,IPv6>
                mtu 1480 index 3
             inet tunnel src 109.146.85.57   tunnel dst 109.146.85.212
             tunnel hop limit 60
             inet6 fe80::6d92:5539/10 --> fe80::6d92:55d4

     ip.tun0:1: flags=2200851<UP,POINTOPOINT,RUNNING,MULTICAST,NONUD,IPv6>
               mtu 1480 index 3
             inet6 2::45/128 --> 2::46

  Configuring IPv4/IPv6 Tunnels
     An IPv4 over IPv6 tunnel interface can send and receive IPv4
     packets  encapsulated in an IPv6  packet. Create tunnels  at
     both ends  pointing to each other. IPv4  over  IPv6  tunnels
     require  the tunnel source  and  tunnel destination IPv6 and
     IPv4  addresses.  The  following   demonstrates  auto-tunnel
     configuration:

     example% ifconfig ip6.tun0 inet plumb tsrc my-ipv6-address \
        tdst peer-ipv6-address my-ipv4-address \
        peer-ipv4-address up

     This creates a configured tunnel between my-ipv6-address and
     peer-ipv6-address with my-ipv4-address and peer-ipv4-address
     as  the  endpoints  of  the  point-to-point  interface,  for
     example:

     example% ifconfig ip6.tun0 inet plumb tsrc fe80::1 tdst fe80::2 10.0.0.208 \
         10.0.0.210 up

     To show all IPv4 interfaces that are up and configured:

     example% ifconfig -au4
     lo0: flags=1000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4> mtu 8232 index 1
          inet 127.0.0.1 netmask ff000000
     hme0: flags=1004843<UP,BROADCAST,RUNNING,MULTICAST,DHCP,IPv4> mtu 1500 index 2
          inet 129.153.128.208 netmask ffffff00 broadcast 129.153.128.255
     ip6.tun0: flags=10008d1<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST,IPv4> mtu \
          1460 index 3
          inet6 tunnel src fe80::1 tunnel dst fe80::2
          tunnel hop limit 60 tunnel encapsulation limit 4
          inet 10.0.0.208 --> 10.0.0.210 netmask ff000000


EXAMPLES

     Example 1: Using the ifconfig Command

     If your workstation is not attached to an Ethernet, the  le0
     interface should be marked "down" as follows:

     example% ifconfig le0 down

     Example 2: Printing Addressing Information

     To print out the addressing information for each  interface,
     use the following command:

     example% ifconfig -a

     Example 3: Resetting the Broadcast Address

     To reset each interface's broadcast address after  the  net-
     masks have been correctly set, use the next command:

     example% ifconfig -a broadcast +

     Example 4: Changing the Ethernet Address

     To change the Ethernet address for interface  le0,  use  the
     following command:

     example% ifconfig le0 ether aa:1:2:3:4:5

     Example 5: Configuring an IP-in-IP Tunnel

     To configure an IP-in-IP tunnel, first  plumb  it  with  the
     following command:

     example% ifconfig ip.tun0 plumb

      Then configure it as a point-to-point interface,  supplying
     the tunnel source and the tunnel destination:

     example% ifconfig ip.tun0 myaddr mydestaddr tsrc another_myaddr \
                tdst a_dest_addr up

     Tunnel security properties must be configured on one invoca-
     tion of ifconfig:

     example% ifconfig ip.tun0 encr_auth_algs md5 encr_algs 3des

     Example 6: Requesting a Service Without Algorithm Preference

     To request a  service  without  any  algorithm  preferences,
     specify any:

     example% ifconfig ip.tun0 encr_auth_algs any encr_algs any

     Example 7: Disabling All Security

     To disable all security, specify any security  service  with
     none as the algorithm value:

     example% ifconfig ip.tun0 auth_algs none

     or

     example% ifconfig ip.tun0 encr_algs none

     Example 8: Configuring 6to4 Tunnels

     To configure 6to4 tunnels, use the following commands:

     example% ifconfig ip.6to4tun0 inet6 plumb
     example% ifconfig ip.6to4tun0 inet6 tsrc IPv4-address 6to4-address/64 up

     IPv4-address denotes the address of the encapsulating inter-
     face.  6to4-address  denotes  the  address of the local IPv6
     address of form 2002:IPv4-address:SUBNET-ID:HOSTID.

     The long form should be used to resolve any  potential  con-
     flicts that might arise if the system administrator utilizes
     an addressing plan where the values for SUBNET-ID or  HOSTID
     are reserved for something else.

     After the interface is plumbed, a 6to4 tunnel can be config-
     ured as follows:

     example% ifconfig ip.6to4tun0 inet6 tsrc IPv4-address up

     This short form sets the address. It uses the convention:

     2002:IPv4-address::1

     The SUBNET-ID is 0, and the HOSTID is 1.


FILES

     /etc/netmasks
           netmask data


ATTRIBUTES

     See attributes(5) for descriptions of the  following  attri-
     butes:

  /usr/sbin
     ____________________________________________________________
    |       ATTRIBUTE TYPE        |       ATTRIBUTE VALUE       |
    |_____________________________|_____________________________|
    | Availability                | SUNWcsu                     |
    |_____________________________|_____________________________|
    | Interface   Stability   for | Evolving                    |
    | options modlist, modinsert, |                             |
    | and modremove               |                             |
    |_____________________________|_____________________________|

  /sbin

     ____________________________________________________________
    |       ATTRIBUTE TYPE        |       ATTRIBUTE VALUE       |
    |_____________________________|_____________________________|
    | Availability                | SUNWcsr                     |
    |_____________________________|_____________________________|
    | Interface   Stability   for | Evolving                    |
    | options modlist, modinsert, |                             |
    | and modremove               |                             |
    |_____________________________|_____________________________|


SEE ALSO

     dhcpinfo(1),  dhcpagent(1M),  in.mpathd(1M),  in.routed(1M),
     ndd(1M),  netstat(1M), ethers(3SOCKET), gethostbyname(3NSL),
     getnetbyname(3SOCKET), hosts(4),  netmasks(4),  networks(4),
     nsswitch.conf(4),   attributes(5),   arp(7P),   ipsecah(7P),
     ipsecesp(7P), tun(7M)

     System Administration Guide: IP Services


DIAGNOSTICS

     ifconfig sends messages that indicate if:

        o  the specified interface does not exist

        o  the requested address is unknown

        o  the user is not  privileged  and  tried  to  alter  an
           interface's configuration


NOTES

     Do not select the names broadcast, down, private,  trailers,
     up  or  other  possible  option  names  when you choose host
     names. If you choose any one of these names as  host  names,
     it  can  cause unusual problems that are extremely difficult
     to diagnose.


Man(1) output converted with man2html