mountall, umountall - mount, unmount multiple file systems
mountall [-F FSType] [-l | -r] [file_system_table]
umountall [-k] [-s] [-F FSType] [-l | -r] [-n]
umountall [-k] [-s] [-h host] [-n]
mountall is used to mount file systems specified in a file
system table. The file system table must be in vfstab(4)
format. If no file_system_table is specified, /etc/vfstab is
used. If - is specified as file_system_table, mountall reads
the file system table from the standard input. mountall
mounts only those file systems with the mount at boot field
set to yes in the file_system_table.
For each file system in the file system table, the following
logic is executed: if there exists a
file/usr/lib/fs/FSType/fsckall, where FSType is the type of
the file system, save that file system in a list to be
passed later, and all at once, as arguments to the
/usr/lib/fs/FSType/fsckall script. The
/usr/lib/fs/FSType/fsckall script checks all of the file
systems in its argument list to determine whether they can
be safely mounted. If no /usr/lib/fs/FSType/fsckall script
exists for the FSType of the file system, the file system is
individually checked using fsck(1M). If the file system does
not appear mountable, it is fixed using fsck before the
mount is attempted. File systems with a - entry in the
fsckdev field are mounted without first being checked.
umountall causes all mounted file systems except root, /usr,
/var, /var/adm, /var/run, /proc, and /dev/fd to be
unmounted. If the FSType is specified, mountall and umoun-
tall limit their actions to the FSType specified. There is
no guarantee that umountall unmounts busy file systems, even
if the -k option is specified.
The following options are supported:
-F Specify the FSType of the file system to be mounted or
Unmount all file systems listed in /etc/mnttab that
are remote-mounted from host.
-k Use the fuser -k mount-point command. See the
fuser(1M) for details. The -k option sends the SIG-
KILL signal to each process using the file. As this
option spawns kills for each process, the kill mes-
sages might not show up immediately. There is no
guarantee that umountall unmounts busy file systems,
even if the -k option is specified.
-l Limit the action to local file systems.
-n List the actions that would be performed for the
specified options, but do not actually execute these
actions. Repeating the command without the -n option
executes the listed actions, assuming that the
/etc/mnttab file has not changed in the interval prior
to repeating the command.
-r Limit the action to remote file system types.
-s Do not perform the umount operation in parallel.
Mounted file system table
Table of file system defaults
Script called by mountall to perform the file system
check of all file systems of type FSType
See attributes(5) for descriptions of the following attri-
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
| Availability | SUNWcsu |
fsck(1M), fuser(1M), mount(1M), mnttab(4), vfstab(4), attri-
No messages are printed if the file systems are mountable
Error and warning messages come from fsck(1M) and mount(1M).
Man(1) output converted with