raidctl(1M)




NAME

     raidctl - RAID hardware utility


SYNOPSIS

     raidctl [-f] -c primary_disk secondary_disk

     raidctl [-f] -c -r 1 primary_disk secondary_disk

     raidctl [-f] -c -r 0 disk1 disk2 [disk3...disk8]

     raidctl [-f] -d volume

     raidctl [-f] -F filename controller...

     raidctl [-f] -l [controller...]


DESCRIPTION

     The raidctl  utility  creates,  deletes,  or  displays  RAID
     volumes  of the LSI1030, LSI1064, LSI1066, and LSI1068 RAID-
     enabled    controllers.    The    utility    also    updates
     firmware/fcode/BIOS for these controllers.

     The raidctl utility requires privileges that are  controlled
     by  the  underlying file-system permissions. Only privileged
     users can manipulate the RAID  system  configuration.  If  a
     non-privileged  user  attempts  to  create  or delete a RAID
     volume, the command fails with EPERM.

     The LSI1030 SCSI HBA supports a single RAID 1  volume.  This
     volume  is  a  simple  two-disk mirror, called an Integrated
     Mirror, or IM. An IM volume can be  created  on  an  LSI1030
     only  if  the  secondary disk has a capacity greater than or
     equal to the primary disk and  there  are  no  file  systems
     mounted on the secondary disk.

     The LSI1064 and LSI1068  HBA  can  enable  up  to  two  RAID
     volumes  and,  in  addition to IM volumes, also supports the
     RAID 0 volume type, called  an  Integrated  Stripe,  or  IS.
     Volumes  of  either  RAID  type can be created on an LSI1064
     only when no member disks have mounted file systems, as  the
     volume initialization destroys any data on member disks.

     For users of x86 platforms: Because of the disk partitioning
     on  x86-based platforms, users of the LSI1064 on these plat-
     forms must verify that no other portion of a disk is in  use
     before committing a disk for use as a RAID volume.

     Without options, raidctl displays the  current  RAID  confi-
     guration on all exisiting controllers.


OPTIONS


     Described below are the supported options. You can insert an
     -f (force) option before each of the options, except -l. The
     effect of the use of -f is described for each option. Notice
     that  the  creation and deletion of RAID volumes can involve
     removal of data from a medium. For this reason,  you  should
     exercise caution when using the -f option.

     -c primary_disk secondary_disk
           Create a mirror using primary_disk and secondary_disk.
           Replace  the  contents of secondary_disk with the con-
           tents of primary_disk. Specify the disk  in  canonical
           form, for example, c0t0d0.

           When you create a RAID volume, the RAID volume assumes
           the  identity  of  the  first  target in the disk pair
           (primary_disk).  The  second  target  (secondary_disk)
           becomes  invisible  and the RAID volume appears as one
           disk.

           When used with controllers  other  than  LSI1030,  the
           creation  of  a  mirror with this option is by default
           interactive. You must answer a prompt affirmatively to
           create  the volume. You can use the -f option to force
           the volume creation.

     -c -r 1 primary_disk secondary_disk
           Create  a  RAID  1  mirror  between  primary_disk  and
           secondary_disk.  This  is the default action of the -c
           option, as described in the preceding entry.

     -c -r 0 disk1 disk2 [disk3...disk8]
           Create a RAID 0 striped LUN on  the  specified  disks.
           There  can  be  up  to  eight members in the LUN. This
           option is not available on the LSI1030.  You  can  use
           the -f option to force the volume creation.

     -d volume (for on board)
           Delete the RAID volume specified  as  volume.  Specify
           volume in canonical form, for example, c0t0d0.

           When a RAID 1 (IM) volume is deleted, the primary  and
           secondary  disks  are  "split".  If  the volume was in
           SYNCING state, the primary will contain the data,  and
           the  secondary  will  not. If the volume state was OK,
           both disks will contain a complete image of the data.

           When a RAID 0 (IS) volume  is  deleted,  all  data  is
           lost. Therefore, the deletion of striped volumes is by
           default interactive.

           You can use the -f option to bypass  any  prompts  and
           force deletion.

     -F filename controller (for HBA)
           Update the firmware  running  on  the  specified  con-
           troller  (controller). You can use the -f to force the
           update.

     -l [controller ...]
           List the system's RAID configuration. If controller is
           specified, list RAID configurations for controller.

           Output from the -l lists the following information:

           RAID Volume
                 Displays logical RAID volume name.

           Volume Type
                 Can be one of IS or IM. IS stands for integrated
                 stripe  and  means  that  the volume is a RAID 0
                 volume. IM  stands  for  integrated  mirror  and
                 means that a volume is a RAID 1 volume.

           RAID Status
                 Displays RAID status as either RESYNCING  (disks
                 are  syncing),  DEGRADED (RAID is operating with
                 reduced    functionality),     OK     (operating
                 optimally), or FAILED (non-functional).

           RAID Disk
                 Displays RAID disk name.

           Disk Status
                 Displays disk status as either OK or FAILED.


EXAMPLES

     Example 1: Creating the RAID Configuration

     The following command creates an IM:

     example# raidctl -c c0t0d0 c0t1d0

     The following command creates an IS:

     example# raidctl -c -r 0 c0t2d0 c0t3d0

     Example 2: Displaying the RAID Configuration

     The following command displays the RAID configuration:

     example# raidctl
     RAID    Volume  RAID            RAID            Disk
     Volume  Type    Status          Disk            Status
     ------------------------------------------------------
     c0t2d0  IS      OK              c0t2d0          OK
                                     c0t3d0          OK
     c0t0d0  IM      RESYNCING       c0t0d0          OK
                                     c0t1d0          OK

     Example 3: Deleting the RAID Configuration

     The following command deletes an IM volume on an LSI1030:

     example# raidctl -d c0t0d0
     RAID Volume 'c0t0d0' deleted

     The following command deletes an IS volume on an LSI1064:

     example# raidctl -d c0t0d0
     Deleting volume c0t0d0 will destroy all data it contains, proceed
     (yes/no)? yes
     Volume 'c0t0d0' deleted

     Example 4: Updating Flash Images on the Controller

     The following command  updates  flash  images  on  the  con-
     troller:

     example# raidctl -F lsi_image.fw 0
     Update flash image on controller 0? (y/n): y
     Flash updated successfully


EXIT STATUS

     The following exit values are returned:

     0     Successful completion.

     1     Invalid command line input.

     2     Request operation failed.


ATTRIBUTES

     See attributes(5) for descriptions of the  following  attri-
     butes:

     ____________________________________________________________
    |       ATTRIBUTE TYPE        |       ATTRIBUTE VALUE       |
    |_____________________________|_____________________________|
    | Availability                | SUNWcsu                     |
    |_____________________________|_____________________________|


SEE ALSO

     attributes(5)

     System Administration Guide: Basic Administration


Man(1) output converted with man2html