update_drv(1M)




NAME

     update_drv - modify device driver attributes


SYNOPSIS

     update_drv [-f] [-v] device_driver

     update_drv [-b basedir]  [-f]  [-v]  -a  -i  'identify-name'
     device_driver

     update_drv  [-b  basedir]  [-f]  [-v]  -a  -m   'permission'
     device_driver

     update_drv [-b basedir] [-f] [-v] -a -i  'identify-name'  -m
     'permission' device_driver

     update_drv [-b basedir]  [-f]  [-v]  -d  -i  'identify-name'
     device_driver

     update_drv  [-b  basedir]  [-f]  [-v]  -d  -m   'permission'
     device_driver

     update_drv [-b basedir] [-f] [-v] -d -i  'identify-name'  -m
     'permission' device_driver


DESCRIPTION

     The update_drv command informs the  system  about  attribute
     changes  to  an  installed  device driver. It can be used to
     re-read the driver.conf(4)  file,  or  to  add,  modify,  or
     delete a driver's minor node permissions or aliases.

     Without options, update_drv reloads the driver.conf file.

     Upon successfully updating the aliases, the  driver  binding
     takes effect upon reconfig boot or hotplug of the device.

     Upon successfully updating the  permissions,  only  the  new
     driver minor nodes get created with the modified set of file
     permissions. Existing driver minor nodes do  not  get  modi-
     fied.


OPTIONS

     The following options are supported:

     -a    Add a permission or aliases entry.

           With the  -a  option  specified,  a  permission  entry
           (using  the  -m  option)  or  a driver's aliases entry
           (using the -i option) can be added or  updated.  If  a
           matching  minor  node permissions entry is encountered
           (having the same driver name and the minor  node),  it
           is  replaced.  If  a matching aliases entry is encoun-
           tered (having a different driver  name  and  the  same
           alias), an error is reported.

           The -a and -d options are mutually exclusive.

     -b basedir
           Installs or modifies the driver on the system  with  a
           root  directory  of  basedir rather than installing on
           the system executing update_drv.

     -d    Delete a permission or aliases entry.

           The -m permission or -i identify-name option needs  to
           be specified with the -d option.

           The -d and -a options are mutually exclusive.

           If the  entry  doesn't  exist  update_drv  returns  an
           error.

     -f    Force the system to reread the driver.conf  file  even
           if the driver module cannot be unloaded. See NOTES.

     -i 'identify-name'
           A  white-space  separated  list  of  aliases  for  the
           driver.  If -a or -d option is not specified then this
           option is ignored. The identify-name string is  manda-
           tory.  If  all aliases need to be removed, rem_drv(1M)
           is recommended.

     -m 'permission'
           Specify a white-space separated list  of  file  system
           permissions  for the device node of the device driver.
           If -a or -d option is not specified then, this  option
           is ignored.  The permission string is mandatory.


EXAMPLES

     Example 1: Adding or Modifying an Existing Minor Permissions
     Entry

     The following command adds or modifies  the  exisitng  minor
     permissions entry of the clone driver:

     example# update_drv -a -m 'llc1 777 joe staff' clone

     Example 2: Removing All Minor Permissions Entries

     The following command removes all minor  permission  entries
     of the usbprn driver, the USB printer driver:

     example# update_drv -d -m '* 0666 root sys' usbprn

     Example 3: Adding a Driver Aliases Entry

     The following command adds a driver  aliases  entry  of  the
     ugen driver with the identity string of usb459,20:

     example# update_drv -a -i '"usb459,20"' ugen

     Example 4: Re-reading the  driver.conf  File  For  the  ohci
     Driver

     The following command re-reads the driver.conf(4) file.

      example# update_drv ohci


EXIT STATUS

     The following exit values are returned:

     0     Successful completion.

     >0    An error occurred.


ATTRIBUTES

     See attributes(5) for descriptions of the  following  attri-
     butes:

     ____________________________________________________________
    |       ATTRIBUTE TYPE        |       ATTRIBUTE VALUE       |
    |_____________________________|_____________________________|
    | Availability                | SUNWcsu                     |
    |_____________________________|_____________________________|


SEE ALSO

     add_drv(1M),  modunload(1M),  rem_drv(1M),   driver.conf(4),
     attributes(5)


NOTES

     If -a or -d options are specified, update_drv does  not  re-
     read the driver.conf file.

     A  forced  update  of  the  driver.conf  file  reloads   the
     driver.conf file without reloading the driver binary module.
     In this case, devices which can not  be  detached  reference
     driver  global  properties  from  the  old driver.conf file,
     while the remaining driver instances reference  global  pro-
     perties in the new driver.conf file.

     It is possible to add an alias , which  changes  the  driver
     binding  of  a  device  already being managed by a different
     driver. A force update (-f) with the -a option tries to bind
     the  new  driver  and  reports an error if it cannot. If you
     specify both the -m and -i option, a force update  tries  to
     modify  the alias even if permissions modification fails and
     vice-versa. A force update  with  the  -d  option  tries  to
     delete entries and reports the error if it cannot.


Man(1) output converted with man2html