ypinit - set up NIS client
/usr/sbin/ypinit [-c] [-m] [-s master_server]
ypinit can be used to set up an NIS client system. You
must be the superuser to run this command. This script need
not be used at all if ypbind(1M) is started with the -broad-
cast option (it is invoked with this option from the start
up script /etc/init.d/rpc).
Normally, ypinit is run only once after installing the sys-
tem. It may be run whenever a new NIS server is added to the
network or an existing one is decommissioned.
ypinit prompts for a list of NIS servers to bind the client
to; this list should be ordered from the closest to the
furthest server. Each of these NIS servers must be listed in
either the /etc/hosts or the /etc/inet/ipnodes file along
with its IP address. ypinit stores the list in file
/var/yp/binding/domain/ypservers. This file is used by
ypbind when run without the -broadcast option.
- c Set up a ypclient system.
-m Build a master ypserver data base.
Slave data base. master_server must be the same master
configured in the YP maps and returned by the ypwhich
See attributes(5) for descriptions of the following attri-
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
| Availability | SUNWnisu |
ypbind(1M), sysinfo(2), hosts(4), ipnodes(4), attributes(5)
ypinit sets up the list of NIS servers only for the current
domain on the system when it is run, that is, the domain
returned by the SI_SRPC_DOMAIN command to sysinfo(2). Care
should be taken to ensure that this is the same as the
desired domain for NIS client processes.
Man(1) output converted with