e1000g(7D)




NAME

     e1000g - Intel Gigabit, 82542,  82543,  82544,  82540  based
     network interface controllers


SYNOPSIS

     /dev/e1000g


DESCRIPTION

     The e1000g Ethernet driver  is  a  multithreaded,  loadable,
     clonable, STREAMS hardware driver supporting the connection-
     less Data Link  Provider  Interface,  dlpi(7P),  over  Intel
     Gigabit  controllers.  Multiple  Intel  Gigabit  controllers
     installed within the system are supported by the driver. The
     e1000g  driver  provides basic support for the Intel Gigabit
     controllers. Functions include  chip  initialization,  frame
     transmit  and receive, multicast support, and error recovery
     and reporting.


APPLICATION PROGRAMMING INTERFACE

     The cloning, character-special device /dev/e1000g is used to
     access  all  Intel Gigabit devices installed within the sys-
     tem.

  e1000g and DLPI
     The e1000g driver is a self-sufficient DLPI module that pro-
     vides  all  the  LAN  driver  and STREAMS functionality; the
     /kernel/misc/gld module is not required.

     The values returned by the driver in the DL_INFO_ACK  primi-
     tive  in  response  to  the DL_INFO_REQ from the user are as
     follows:

        o  The maximum SDU (with  jumbo  frame)  is  16128  (ETH-
           ERMTU).

        o  The minimum SDU is 0. The driver pads to the mandatory
           60-octet minimum packet size.

        o  The dlsap address length is 8.

        o  The MAC type is DL_ETHER.

        o  The sap length  value  is  -2,  meaning  the  physical
           address  component is followed immediately by a 2-byte
           sap component within the DLSAP address.

        o  The broadcast address value is Ethernet/IEEE broadcast
           address (FF:FF:FF:FF:FF:FF).


CONFIGURATION

     The e1000g driver does not support the use of shared RAM  on
     the board.
     To configure the e1000g driver:

        o  Use prtconf -v  |  grep  pci8086,[12][01][01][0-F]  to
           obtain the instance number of the driver.

        o  Use ifconfig e1000ginstance plumb to  plumb  the  con-
           troller.

        o  Use ifconfig e1000ginstance inet ip_address netmask  +
           broadcast + -trailers up to bring up the interface.

        o  Use the ping(1M) command to contact interfaces on  the
           network  to  verify  that  the configuration is opera-
           tional.

  Configuration File Options
     The following  e100g.conf  configuration  options  are  sup-
     ported:

     AutoNegAdvertised
           This is a bitmap  for  the  speeds  advertised  during
           autonegotiation.

           Bit    |  7  |  6  |   5   |   4   |  3   |  2   |  1  |  0
           Setting| N/A | N/A | 1000F |  N/A  | 100F | 100H | 10F | 10H

           The adapter only autonegotiates to a  speed  which  is
           advertised.  For example: AutoNegAdvertised = 4 causes
           an adapter to only advertise  autonegotiation  at  100
           Mbps, full duplex. No other link speeds is accepted or
           given  during  autonegotiation.   AutoNegAdvertised=47
           advertises  all  speeds available, This is the same as
           using the default setting of 0.

           0-255 Allowed values

           0     Default

     DmaFairness
           When enabled, direct memory access by  the  driver  is
           fair,  meaning  transmit and receive have equal prior-
           ity.  When  disabled,  receive  takes  priority   over
           transmit.

           The allowed values are:

           0     Disable.

           1     Enable.This is the default.

     FlowControl
           Flow control utilizes ethernet  XON  and  unicast  and
           multicast  XOFF packets to allow ethernet equipment to
           slow down the stream of data between two ethernet dev-
           ices.

           The allowed values are:

           0     Disable.  Packets  can  get  dropped   in   high
                 throughput  situations,  leading to reduced net-
                 work performance.

           1     Receive only.

           2     Transmit only.

           3     Receive and transmit. This is the default.

           4     Use adapter's EEPROM-programmed factory  default
                 setting.

     ForceSpeedDuplex
           Specify the speed and duplex mode for each instance.

           If you set ForceSpeedDuplex=7,4, the e1000g0 is set to
           autonegotiate  and  e1000g1  is  set to 100 Mbps, full
           duplex.

           Fiber optic ethernet adapters ignore this setting.

           The allowed values are:

           1     10 Megabits per second, Half Duplex.

           2     10 Megabits per second, Full Duplex.

           3     100 Megabits per second, Half Duplex.

           4     100 Megabits per second, Full Duplex.

           7     Autonegotiate  speed  and  duplex.This  is   the
                 default.

     MaxFrags
           Maximum number of STREAMS memory buffer  fragmentation
           of incoming or outgoing packets. This value can effect
           the performance and memory requirements of the driver.

           2-8   Allowed values

           8     Default

     MaxFrameSize
           Upper limit on the maximum MTU size the driver allows.
           All  Intel  gigabit  adapters,  except the 82542-based
           Intel PRO/1000 adapter,  allow  the  configuration  of
           jumbo frames.

           The maximum MTU accepted by  the  MAC  is  16128.  Use
           ifconfig(1M)  To configure jumbo frames. ifconfig with
           the adapter instance and the  mtu  argument  (ifconfig
           e1000g0  mtu 16128) configures adapter e1000g0 for the
           maximum allowable jumbo frame size.

           The allowed values are:

           0     Standard ethernet frames with  a  MTU  equal  to
                 1500. This is the default.

           1     Jumbo frames with a maximum MTU of 4096.

           2     Jumbo frames with a maximum MTU of 8192.

           3     Jumbo frames with a maximum MTU of 16384.

     MaxFreeListBuf
           Maximum number or pre-allocated buffers the driver can
           use for received data. Pre-allocating buffers can help
           with receive performance. It also increases the memory
           requirements of the driver.

           0-4096
                 Allowed values

           256   Default

     MaxNumReceivePackets
           Maximum number of receive packets that the driver  can
           handle for each interrupt.

           CPU utilization can be lowered through more  effecient
           interrupt  management. If this value is increased, the
           time needed by  the  CPU  to  process  the  individual
           interrupts  can  increase  and nullify any performance
           gains realized by handling less interrupts.

           16-1024
                 Allowed values

           32    Default

     MWIEnable
           x86 Architecture servers  based  on  the  Intel  450NX
           chipset  are  known to have problems with Memory Write
           and Invalidate. Disable this  feature  only  for  this
           chipset.

           The allowed values are:

           0     Disable. This is the default.

           1     Enable.

     NumRxDescriptors
           Number of receive descriptors available to the driver.
           More  receive descriptors increase receive performance
           at the penalty of decreased available memory.

           If you set this value to 256 on Solaris 7 when  multi-
           ple  Intel  Gigabit  NICs  are  configured,  it causes
           memory allocation problems. It is recommended that you
           set this value lower when using multiple Intel Gigabit
           adapters on Solaris 7.

           80-256
                 Allowed values

           256   Default

     NumTxDescriptors
           Number  of  transmit  descriptors  available  to   the
           driver.  More  transmit  descriptors increase transmit
           performance at  the  penalty  of  decreased  available
           memory.

           If you set this value to 256 on Solaris 7 when  multi-
           ple  Intel  Gigabit  NICs  are  configured,  it causes
           memory allocation problems. It is recommended that you
           set this value lower when using multiple Intel Gigabit
           adapters on Solaris 7.

           80-256
                 Allowed values

           256   Default

     ProfileJumboTraffic
           If you need  to  collect  statistics  on  jumbo  frame
           usage,  enabling  this  parameter  causes  the  e1000g
           driver to keep a count of the number of  jumbo  frames
           transmitted  and  received. Use the netstat -k command
           to  view  jumbo  frame  utilization  statistics.   See
           netstat(1M)

           The allowed values are:

           0     Disable. This is the default.

           1     Enable.

     TbiCompatibilityEnable=1;
           You must enable this feature  on  Intel  82543CG-based
           copper  adapters  to  operate  correctly with TBI mode
           ethernet hardware.

           The allowed values are:

           0     Disable.

           1     Enable. This is the default.

     TxInterruptDelay
           Amount of time (in 1.024 micro second  units)  between
           the  time  transmit  data  is  queued  in  a  transmit
           descriptor and the transmit interrupt is sent.

           0-65535
                 Allowed values. A value of 0 completely disables
                 any  transmit  interrupt  delay.  Some  delay is
                 benefical in reducing  CPU  utilization  by  the
                 driver.

           300   Default.


FILES

     /dev/e1000g

     e1000g
           Character special device

     /kernel/drv/e1000g.conf
           Configuration file of e1000g driver

     sys/stropts.h
           stropts network header file

     sys/ethernet.h
           Ethernet network header file

     sys/dlpi.h
           dlpi network header file


ATTRIBUTES

     See attributes(5) for descriptions of the  following  attri-
     butes:

     ____________________________________________________________
    |       ATTRIBUTE TYPE        |       ATTRIBUTE VALUE       |
    |_____________________________|_____________________________|
    | Architecture                | x86                         |
    |_____________________________|_____________________________|


SEE ALSO

     ifconfig(1M), netstat(1M), ping(1M), attributes(5), dlpi(7P)

     Intel PRO/1000 Gigabit Adapter Driver Installation Notes for
     Solaris


Man(1) output converted with man2html