elx(7D)




NAME

     elx - 3COM EtherLink III Ethernet device driver


SYNOPSIS

     #include <sys/stropts.h>

     #include <sys/ethernet.h>

     #include <sys/dlpi.h>

     #include <sys/gld.h>


DESCRIPTION

     The  elx Ethernet  driver  is  a  multi-threaded,  loadable,
     clonable, STREAMS hardware driver supporting the connection-
     less Data Link Provider Interface, dlpi(7P), over  the  fol-
     lowing  3COM  ETHERLINK  III  Ethernet  controllers. For x86
     based systems:  3C509, 3C509B,  3C579 and 3C59x controllers.
     Multiple EtherLink III controllers installed within the sys-
     tem are supported by the driver. The   elx  driver  provides
     basic  support  for  the  EtherLink  III hardware. Functions
     include chip initialization,  frame  transmit  and  receive,
     multicast  and "promiscuous" support, and error recovery and
     reporting.

     The cloning, character-special device /dev/elx  is  used  to
     access  all  EtherLink III devices installed within the sys-
     tem.

     The  elx driver is dependent on /kernel/misc/gld, a loadable
     kernel module that provides the elx driver with the DLPI and
     STREAMS functionality required of a LAN driver.  See gld(7D)
     for more details on the primatives supported by the driver.

     The values returned by the driver in the DL_INFO_ACK  primi-
     tive  in  response  to  the DL_INFO_REQ from the user are as
     follows:

        o  The maximum SDU is  1500 (ETHERMTU).

        o  The minimum SDU is  0. The driver will pad to the man-
           datory 60-octet minimum packet size.

        o  The  dlsap address length is  8.

        o  The MAC type is DL_ETHER.

        o  The sap length value  is   -2,  meaning  the  physical
           address  component is followed immediately by a 2-byte
           sap component within the DLSAP address.

        o  The broadcast address value is Ethernet/IEEE broadcast
           address (FF:FF:FF:FF:FF:FF).


FILES

     /dev/elx
           special character device

     /platform/i86pc/kernel/drv/elx.conf
           configuration file for elx driver


ATTRIBUTES

     See attributes(5) for descriptions of the  following  attri-
     butes:

     ____________________________________________________________
    |       ATTRIBUTE TYPE        |       ATTRIBUTE VALUE       |
    |_____________________________|_____________________________|
    | Architecture                | x86                         |
    |_____________________________|_____________________________|


SEE ALSO

     attributes(5), dlpi(7P), gld(7D)


Man(1) output converted with man2html