ifp(7D)




NAME

     ifp - ISP2100 Family Fibre Channel Host Bus Adapter Driver


SYNOPSIS

     PCI   SUNW,ifp@pci-slot


DESCRIPTION

     The ifp Host Bus Adapter is a SCSA  compliant  nexus  driver
     for  the  Qlogic ISP2100/ISP2100A chips. These chips support
     Fibre Channel Protocol for SCSI  on  Private  Fibre  Channel
     Arbitrated loops.

     The ifp driver interfaces  with  SCSI  disk  target  driver,
     ssd(7D),  and the SCSI-3 Enclosure Services driver, ssd(7D).
     Only SCSI devices of type disk  and  ses  are  supported  at
     present time.

     The ifp driver supports the standard functions  provided  by
     the  SCSA  interface. It supports auto request sense (cannot
     be turned off) and tagged queueing by  default.  The  driver
     requires that all devices have unique hard addresses defined
     by switch settings in  hardware.  Devices  with  conflicting
     hard addresses will not be accessible.


FILES

     /kernel/drv/ifp
           ELF Kernel Module

     /kernel/drv/sparcv9/ifp
           ELF Kernel Module (64-bit version)

     /kernel/drv/ifp.conf
           Driver configuration file


ATTRIBUTES

     See attributes(5) for descriptions of the  following  attri-
     butes:

     ____________________________________________________________
    | ATTRIBUTE  TYPE             | ATTRIBUTE                   |ALUE
    |_____________________________|_____________________________|
    | Availability                | SPARC                       |
    |_____________________________|_____________________________|


SEE ALSO

     luxadm(1M),prtconf(1M),driver.conf(4),attributes(5),ses(7D),ssd(7D)

     Writing Device Drivers,

     ANSI X3.272-1996, Fibre Channel Arbitrated Loop (FC-AL),

     ANSI X3.269-1996, Fibre Channel Protocol for SCSI (FCP),

     ANSI X3.270-1996, SCSI-3 Architecture Model (SAM),

     Fibre Channel Private Loop SCSI Direct Attach (FC-PLDA),

     ISP2100 Firmware Interface Specification, QLogic Corporation


DIAGNOSTICS

     The messages described below are some that may appear on the
     system console, as well as being logged.

      This first set of messages may be displayed while  the  ifp
     driver is initially trying to attach.  All of these messages
     mean that the ifp driver was unable to attach.  These   mes-
     sages are preceded by "ifp<number>", where "<number>" is the
     instance number of the ISP2100 Host Bus Adapter.

          Device is using a hilevel intr, unused
                The device was configured with an interrupt level
                that  cannot be used with this ifp driver.  Check
                the device.

          Failed to alloc soft state
                Driver was  unable  to  allocate  space  for  the
                internal  state  structure. Driver did not attach
                to device; SCSI devices will be inaccessible.

          Bad soft state
                Driver requested an invalid internal state struc-
                ture.            Driver did not attach to device;
                SCSI devices will be inaccessible.

          Unable to map pci config registers

          Unable to map biu registers
                Driver was unable to map device registers;  check
                for  bad  hardware. Driver did not attach to dev-
                ice; SCSI devices will be inaccessible.

          Cannot alloc tran
                Driver was unable to obtain a transport handle to
                be  able  to  communicate  with  SCSA  framework.
                Driver did not attach  to  device;  SCSI  devices
                will be inaccessible.

          ddi_create_minor_node failed
                Driver was unable to  create  devctl  minor  node
                that  is used by luxadm(1M) for administering the
                loop. Driver  did  not  attach  to  device;  SCSI
                devices will be inaccessible.

          Cannot alloc dma handle
                Driver was unable allocate a dma handle for  com-
                municating  with the Host Bus Adapter. Driver did
                not attach to device; SCSI devices will be  inac-
                cessible.

          Cannot alloc cmd area
                 Driver  was  unable  allocate  dma  memory   for
                request  and  response  queues.  Driver  did  not
                attach to device; SCSI devices will be inaccessi-
                ble.

          Cannot bind cmd area
                Driver was unable to bind dma handle to  the  cmd
                area.  Driver did not attach to device; SCSI dev-
                ices will be inaccessible.

          Cannot alloc fcal handle
                Driver was  unable  allocate  a  dma  handle  for
                retrieving  loop  map  from the Host Bus Adapter.
                Driver did not attach  to  device;  SCSI  devices
                will be inaccessible.

          Cannot bind portdb
                Driver was unable to bind fcal port handle to the
                memory  used  for obtaining port database. Driver
                did not attach to device; SCSI  devices  will  be
                inaccessible.

          scsi_hba_attach failed
                Driver was unable to attach to  the  SCSA  frame-
                work.  Driver did not attach to device; SCSI dev-
                ices will be inaccessible.

          Unable to create hotplug thread
                Driver was not able to create the  kernel  thread
                used  for hotplug support.  Driver did not attach
                to device; SCSI devices will be inaccessible.

          Cannot add intr
                Driver was not able to add the interrupt  routine
                to the           kernel. Driver did not attach to
                device; SCSI devices will be inaccessible.

          Unable to attach
                Driver was unable to attach to the  hardware  for
                some           reason that may be printed.
                 Driver did not attach to  device;  SCSI  devices
                will be inaccessible.

     The following set of messages may be display  at  any  time.
     They  will be printed with the full device pathname followed
     by the shorter form described above.

          Firmware checksum incorrect
                Firmware has an invalid checksum and will not  be
                downloaded.

          Chip reset timeout
                ISP chip failed to reset in the  time  allocated;
                may  be bad hardware.

          Stop firmware failed
                Stopping  the  firmware  failed;   may   be   bad
                hardware.

          Load ram failed
                Unable to download  new  firmware  into  the  ISP
                chip.

          DMA setup failed
                The DMA setup failed in the host  adapter  driver
                on  a scsi_pkt. This will return TRAN_BADPKT to a
                SCSA target driver.

          Bad request pkt type

          Bad request pkt

          Bad request pkt hdr

          Bad req pkt order
                The ISP Firmware rejected the packet as being set
                up incorrectly. This will cause the ifp driver to
                call the target completion routine with the  rea-
                son  of  CMD_TRAN_ERR  set in the scsi_pkt. Check
                the target driver for correctly  setting  up  the
                packet.

          Firmware error
                The ISP chip encountered a firmware error of some
                kind.  This error will cause the ifp driver to do
                error recovery by resetting the chip.

          DMA Failure (event)
                The ISP chip encountered a DMA error while  read-
                ing  from  the  request  queue (event is 8003) or
                writing to the response queue  (event  is  8004).
                This  error will cause the ifp driver to do error
                recovery by resetting the chip.

          Fatal error, resetting interface
                This is an indication that  the  ifp  driver   is
                doing  error  recovery.  This will cause all out-
                standing commands that have been  transported  to
                the  ifp  driver to be completed via the scsi_pkt
                completion routine in the target driver with rea-
                son of CMD_RESET and status of STAT_BUS_RESET set
                in the scsi_pkt.

          target t, duplicate port wwns
                The driver detected target t  to  be  having  the
                same  port WWN as a different target; this is not
                supposed to happen. Target t will become inacces-
                sible.

          target t, duplicate switch settings
                The driver detected devices with the same  switch
                setting  t. All such devices will become inacces-
                sible.

          WWN changed on target t
                The World Wide Name (WWN) has changed on the dev-
                ice with switch setting t.

          target t, unknown device type dt
                The driver does  not  know  the  device  type  dt
                reported by the device with switch setting t.


Man(1) output converted with man2html