pcn(7D)




NAME

     pcn - AMD PCnet Ethernet controller device driver


SYNOPSIS

     /dev/pcn


DESCRIPTION

     The  pcn Ethernet driver  is  a  multi-threaded,   loadable,
     clonable  driver  for the  AMD PCnet family of Ethernet con-
     trollers that use the Generic  LAN Driver (GLD) facility  to
     implement  the required  STREAMS and Data Link Provider (see
     dlpi(7P)) interfaces.

     This driver supports a number of integrated motherboards and
     add-in  adapters  based on the AMD PCnet-ISA, PCnet-PCI, and
     PCnet-32 controller chips. The  pcn driver functions include
     controller  initialization,  frame   transmit  and  receive,
     functional addresses,  promiscuous  and  multicast  support,
     and error  recovery and reporting.


APPLICATION PROGRAMMING INTERFACE

     The cloning character-special device, /dev/pcn, is  used  to
     access all PCnet devices installed in the system.


pcn and DLPI

     The pcn driver uses the Solaris GLD  module   which  handles
     all  the  STREAMS and DLPI specific functions of the driver.
     It is a style 2 DLPI driver and therefore supports only  the
     connectionless  mode  of  data  transfer.  Thus, a DLPI user
     should issue a DL_ATTACH_REQ primitive to select the  device
     to   be   used.   Valid   DLPI  primitives  are  defined  in
     <sys/dlpi.h>. Refer to dlpi(7P) for more information.

     The device is  initialized  on  the  first  attach  and  de-
     initialized (stopped) on the last detach.

     The values returned by the driver in the DL_INFO_ACK  primi-
     tive in response to a DL_INFO_REQ from the user are:

        o  Maximum  SDU  is   1500   (ETHERMTU   -   defined   in
           <sys/ethernet.h>).

        o  Minimum SDU is 0.

        o  DLSAP address length is 8.

        o  MAC type is DL_ETHER.

        o  sap length value is -2, meaning the  physical  address
           component is followed immediately by a 2-byte sap com-
           ponent within the DLSAP address.

        o  Service mode is DL_CLDLS.

        o  No  optional  quality  of  service  (QOS)  support  is
           included  at  present, accordingly, the QOS fields are
           0.

        o  Provider style is DL_STYLE2.

        o  Version is DL_VERSION_2.

        o  Broadcast address value is the Ethernet/IEEE broadcast
           address (FF:FF:FF:FF:FF:FF).

     Once  in  the  DL_ATTACHED  state,  the  user  must  send  a
     DL_BIND_REQ  to  associate a particular Service Access Point
     (SAP) with the stream.

  Known Problems and Limitations
        o  Occasional data corruption has occurred when  pcn  and
           pcscsi drivers in HP Vectra XU 5/90 and Compaq Deskpro
           XL systems are  used  under  high  network  and   SCSI
           loads.  These drivers do not perform well in a produc-
           tion server. A possible workaround is to  disable  the
           pcn  device  with  the  system BIOS and use a separate
           add-in network interface.

        o  The Solaris pcn driver does not support IRQ 4.


FILES

     /dev/pcn
           Character special device

     /kernel/drv/pcn.conf
           Configuration file


ATTRIBUTES

     See attributes(5) for descriptions of the  following  attri-
     butes:

     ____________________________________________________________
    |       ATTRIBUTE TYPE        |       ATTRIBUTE VALUE       |
    |_____________________________|_____________________________|
    | Architecture                | x86                         |
    |_____________________________|_____________________________|


SEE ALSO

     attributes(5), standards(5), dlpi(7P), streamio(7I)

     Writing Device Drivers

     STREAMS Programming Guide


Man(1) output converted with man2html