spwr - SMC EtherPower II 10/100 (9432) Ethernet device
The spwr Ethernet driver is a multi-threaded, loadable,
clonable, STREAMS hardware driver supporting the connection-
less Data Link Provider Interface, dlpi(7P), over SMC Ether-
Power II 10/100 controllers. Multiple EtherPower II con-
trollers installed within the system are supported by the
driver. The spwr driver provides basic support for the SMC
EtherPower II hardware. Functions include chip initializa-
tion, frame transmit and receive, multicast support, and
error recovery and reporting.
APPLICATION PROGRAMMING INTERFACE
The cloning character-special device /dev/spwr is used to
access all SMC EtherPower II devices installed within the
The spwr driver is dependent on /kernel/misc/gld, a load-
able kernel module that provides the spwr driver with the
DLPI and STREAMS functionality required of a LAN driver.
See gld(7d) for more details on the primitives supported by
The values returned by the driver in the DL_INFO_ACK primi-
tive in response to the DL_INFO_REQ from the user are as
o The maximum SDU is 1500 ( ETHERMTU).
o The minimum SDU is 0. The spwr driver will pad to the
mandatory 60-octet minimum packet size.
o The DLSAP address length is 8.
o The MAC type is DL_ETHER.
o The SAP length value is -2, meaning the physical
address component is followed immediately by a 2-byte
SAP component within the DLSAP address.
o The broadcast address value is Ethernet/IEEE broadcast
Character special device.
Driver configuration file
See attributes(5) for descriptions of the following attri-
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
| Architecture | x86 |
attributes(5), dlpi(7P), gld(7D)
Man(1) output converted with