ddi_regs_map_free(9F)




NAME

     ddi_regs_map_free  -  free  a  previously  mapped   register
     address space


SYNOPSIS

     #include <sys/ddi.h>
     #include <sys/sunddi.h>

     void ddi_regs_map_free(ddi_acc_handle_t *handle);


INTERFACE LEVEL

     Solaris DDI specific (Solaris DDI).


PARAMETERS

     handle
           Pointer to a data access handle  previously  allocated
           by    a    call   to   a   setup   routine   such   as
           ddi_regs_map_setup(9F).


DESCRIPTION

     ddi_regs_map_free() frees the  mapping  represented  by  the
     data  access  handle   handle. This function is provided for
     drivers preparing to  detach  themselves  from  the  system,
     allowing   them   to   release  allocated  system  resources
     represented in the handle.


CONTEXT

     ddi_regs_map_free() must be called from user or kernel  con-
     text.


ATTRIBUTES

     See attributes(5) for descriptions of the  following  attri-
     butes:

     ______________________________________________________________
    |       ATTRIBUTE TYPE        |        ATTRIBUTE VALUE        |
    |_____________________________|_______________________________|
    | Architecture                | PCI Local Bus, SBus, ISA, EISA|
    |_____________________________|_______________________________|


SEE ALSO

     attributes(5), ddi_regs_map_setup(9F)

     Writing Device Drivers


Man(1) output converted with man2html