pci_config_put8(9F)




NAME

     pci_config_get8,     pci_config_get16,     pci_config_get32,
     pci_config_get64,     pci_config_put8,     pci_config_put16,
     pci_config_put32,     pci_config_put64,     pci_config_getb,
     pci_config_getl,      pci_config_getll,     pci_config_getw,
     pci_config_putb,     pci_config_putl,      pci_config_putll,
     pci_config_putw  -  read  or  write  single datum of various
     sizes to the PCI Local Bus Configuration space


SYNOPSIS

     #include <sys/ddi.h>
     #include <sys/sunddi.h>

     uint8_t   pci_config_get8(ddi_acc_handle_t   handle,   off_t
     offset);

     uint16_t  pci_config_get16(ddi_acc_handle_t  handle,   off_t
     offset);

     uint32_t  pci_config_get32(ddi_acc_handle_t  handle,   off_t
     offset);

     uint64_t  pci_config_get64(ddi_acc_handle_t  handle,   off_t
     offset);

     void pci_config_put8(ddi_acc_handle_t handle, off_t  offset,
     uint8_t value);

     void pci_config_put16(ddi_acc_handle_t handle, off_t offset,
     uint16_t value);

     void pci_config_put32(ddi_acc_handle_t handle, off_t offset,
     uint32_t value);

     void pci_config_put64(ddi_acc_handle_t handle, off_t offset,
     uint64_t value);


INTERFACE LEVEL

     Solaris DDI specific (Solaris DDI).


PARAMETERS

     handle
           The    data    access     handle     returned     from
           pci_config_setup(9F).

     offset
           Byte offset from the beginning of the  PCI  Configura-
           tion space.

     value Output data.


DESCRIPTION

     These routines read or write a single datum of various sizes
     from  or  to  the   PCI  Local Bus Configuration space.  The
     pci_config_get8(),  pci_config_get16(),  pci_config_get32(),
     and  pci_config_get64()  functions read 8 bits,  16 bits, 32
     bits,   and   64   bits   of   data,   respectively.     The
     pci_config_put8(),  pci_config_put16(),  pci_config_put32(),
     and pci_config_put64() functions write 8 bits, 16  bits,  32
     bits,  and 64 bits of data, respectively.  The  offset argu-
     ment must be a multiple of the datum size.

     Since the  PCI Local Bus Configuration space is  represented
     in  little endian data format, these functions translate the
     data from or to native host format to or from little  endian
     format.

     pci_config_setup(9F) must be called  before  invoking  these
     functions.


RETURN VALUES

     pci_config_get8(),  pci_config_get16(),  pci_config_get32(),
     and  pci_config_get64()  return the value read from the  PCI
     Local Bus Configuration space.


CONTEXT

     These routines can be called from user, kernel, or interrupt
     context.


ATTRIBUTES

     See attributes(5) for descriptions of the  following  attri-
     butes:

     ____________________________________________________________
    |       ATTRIBUTE TYPE        |       ATTRIBUTE VALUE       |
    |_____________________________|_____________________________|
    | Architecture                | PCI Local Bus               |
    |_____________________________|_____________________________|


SEE ALSO

     attributes(5), pci_config_setup(9F), pci_config_teardown(9F)


NOTES

     These functions are specific to PCI bus device drivers.  For
     drivers  using  these  functions, a single source to support
     devices with multiple bus versions may not be easy to  main-
     tain.

     The functions described in this manual page previously  used
     symbolic   names which specified their data access size; the
     function names have been  changed  so  they  now  specify  a
     fixed-width data size.
      See the  following table for the new name equivalents:

     ____________________________________________________________
    |        Previous Name          New Name                    |
    | pci_config_getb               pci_config_get8             |
    | pci_config_getw               pci_config_get16            |
    | pci_config_getl               pci_config_get32            |
    | pci_config_getll              pci_config_get64            |
    | pci_config_putb               pci_config_put8             |
    | pci_config_putw               pci_config_put16            |
    | pci_config_putl               pci_config_put32            |
    | pci_config_putll              pci_config_put64            |
    |___________________________________________________________|


Man(1) output converted with man2html