pm_create_components(9F)




NAME

     pm_create_components, pm_destroy_components - Create or des-
     troy power-manageable components


SYNOPSIS

     #include <sys/ddi.h>
     #include <sys/sunddi.h>

     int pm_create_components(dev_info_t *dip, int components);

     void pm_destroy_components(dev_info_t *dip);


INTERFACE LEVEL

     Solaris DDI specific (Solaris DDI).


PARAMETERS

     dip   Pointer to the device's dev_info structure

     components
           Number of components to create


DESCRIPTION

     The pm_create_components() and pm_destroy_components() func-
     tions  are  now  obsolete  and  will  be removed in a future
     release.  It  is  recommended  that  the  driver   use   pm-
     components(9) instead.

     The pm_create_components() function creates power-manageable
     components  for  a  device.  It  should  be  called from the
     driver's attach(9E) entry point if  the  device  has  power-
     manageable components.

     The correspondence of components to parts  of  the  physical
     device  controlled  by  the driver are the responsibility of
     the driver.

     The pm_destroy_components() function removes all  components
     from  the  device.  It  should  be  called from the driver's
     detach(9E) entry point.


RETURN VALUES

     The pm_create_components() function returns:

     DDI_SUCCESS
           Components are successfully created.

     DDI_FAILURE
           The device already has components.


CONTEXT

     These functions may be called from user or kernel context.


ATTRIBUTES

     See attributes(5) for descriptions of the  following  attri-
     butes:

     ____________________________________________________________
    |       ATTRIBUTE TYPE        |       ATTRIBUTE VALUE       |
    |_____________________________|_____________________________|
    | Interface stability         | Obsolete                    |
    |_____________________________|_____________________________|


SEE ALSO

     power.conf(4),     pm(7D),      attach(9E),      detach(9E),
     pm_busy_component(9F),  pm_idle_component(9F),  pm(9P),  pm-
     components(9P)

     Writing Device Drivers


Man(1) output converted with man2html