ifparse(1M)




NAME

     ifparse - parse ifconfig command line


SYNOPSIS

     /sbin/ifparse [-fs] addr_family commands


DESCRIPTION

     Use the ifparse command to parse  the  ifconfig(1M)  command
     line  options  and  output  substrings,  one  per  line,  as
     appropriate. If no options are  specified,  ifparse  returns
     the  entire ifconfig command line as a series of substrings,
     one per line.


OPTIONS

     The ifparse command supports the following options:

     -f    Lists only substrings of  the  ifconfig  command  line
           that are relevant to IP network multipath failover

     -s     Lists only substrings of the  ifconfig  command  line
           that are not relevant to IP network multipath failover


OPERANDS

     The ifparse command does not support the  interface  operand
     of the ifconfig command.


EXAMPLES

     Example 1: Parsing Command Line Options Relevant to Failover

     The following example shows the use of the  ifparse  command
     to  parse  the  command  line options relevant to IP network
     multipath failover:

     example# ifparse -f inet 1.2.3.4 up group one addif 1.2.3.5 -failover up
     set 1.2.3.4 up

     Example  2:  Parsing  Command  Line  Options  That  Are  Not
     Relevant to Failover

     The following example shows the use of the  ifparse  command
     to  parse  the command line options that are not relevant to
     IP network multipath failover:

     example# ifparse -s inet 1.2.3.4 up group one addif 1.2.3.5 -failover up
     group one
     addif 1.2.3.5 -failover up

     Example 3: Parsing the Command Line For All Options

     The following example shows the use of the  ifparse  command
     to parse the command line for all ifconfig options:

     example# ifparse inet 1.2.3.4 up group one addif 1.2.3.5 -failover up
     group one
     set 1.2.3.4 up
     addif 1.2.3.5 -failover up


ATTRIBUTES

     See attributes(5) for descriptions of the  following  attri-
     butes:

     ____________________________________________________________
    |       ATTRIBUTE TYPE        |       ATTRIBUTE VALUE       |
    |_____________________________|_____________________________|
    | Availability                | SUNWcsr                     |
    |_____________________________|_____________________________|
    | Stability Level             | Obsolete                    |
    |_____________________________|_____________________________|


SEE ALSO

     ifconfig(1M), attributes(5)


DIAGNOSTICS

       usage: -fs <addr_family> <commands>

         This message indicates an invalid command line.

       ifparse: Not enough space

         This message indicates insufficient memory.

       ifparse: dhcp not supported for inet6

         DHCP operations are not supported for the inet6  address
         family.

       ifparse:   Operation   <operation>   not   supported   for
       <addr_family>

         Most operations cannot be used with  all  address  fami-
         lies.  For  example, the broadcast operation is not sup-
         ported on the inet6 address family.

       ifparse: no argument for <operation>

         Some operations, for example broadcast, require an argu-
         ment.


NOTES

     The ifparse command is classified as an obsolete  interface.
     It  will  likely  be removed in a future release. You should
     not develop applications that depend upon this interface.


Man(1) output converted with man2html