pm_get_normal_power(9F)
NAME
pm_get_normal_power, pm_set_normal_power - get or set a dev-
ice component's normal power level
SYNOPSIS
#include <sys/ddi.h>
#include <sys/sunddi.h>
int pm_get_normal_power(dev_info_t *dip, int component);
void pm_set_normal_power(dev_info_t *dip, int component, int
level);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI)
PARAMETERS
pm_get_normal_power() parameters:
dip Pointer to the device's dev_info structure
component
Number of component from which to get normal power
level
pm_set_normal_power() parameters:
dip Pointer to the device's dev_info structure
component
Number of component for which to set normal power
level
level Component's new normal power level
DESCRIPTION
The pm_get_normal_power() and pm_set_normal_power() func-
tions are now obsolete and will be removed in a future
release. It is recommended that device drivers use new
automatic device Power Management interfaces.
The pm_get_normal_power() function returns the normal power
level of component of the device dip.
The pm_set_normal_power() function sets the normal power
level of component of the device dip to level.
When a device has been power managed and is being returned
to a state to be used by the system, it will be brought to
its normal power level. Except for a power level of 0, which
is defined by the system to mean "powered off," the
interpretation of the meaning of the power level is entirely
up to the driver.
RETURN VALUES
The pm_get_normal_power() function returns:
level The normal power level of the specified component
(a positive integer).
DDI_FAILURE
Invalid component number component or the device
has no components.
CONTEXT
These functions can be called from user or kernel context.
ATTRIBUTES
See attributes(5) for descriptions of the following attri-
butes:
____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|_____________________________|_____________________________|
| Interface stability | Obsolete |
|_____________________________|_____________________________|
SEE ALSO
power.conf(4), pm(7D), pm(9P), power(9E),
pm_busy_component(9F), pm_create_components(9F),
pm_destroy_components(9F), pm_idle_component(9F)
Writing Device Drivers
Man(1) output converted with
man2html